30 berichten aan het bekijken - 1 tot 30 (van in totaal 40)
  • Q:
    Bijdrager
    Pieterr

    Automatisch omzetten van MTS bestanden

    Zoals beloofd hierbij een beschrijving hoe je automatisch MTS bestanden kunt converteren naar M4V met behulp van een Folder Action.

    Het gebruik is als volgt: sleep een of meerdere MTS bestanden op een map Videos en de bestanden worden geconverteerd.

    Hiervoor dient eenmalig een map gemaakt te worden waar een Folder Action aan gekoppeld wordt. Dat gaat op de volgende wijze:

    (0) Installeer ffmpeg
    (1) Open /Applications/Utilities/AppleScript Editor.app
    (2) Copy & Paste het script (zie code) in het Editor window
    (3) Sla het script op als convertmts.scpt in /Library/Scripts/Folder Action Scripts
    (4) Sluit AppleScript Editor
    (5) Rechts-klik op de Desktop, en kies New Folder. Noem de folder “Videos”
    (6) Rechts-klik op de Videos map, en kies Folder Actions Setup…
    (7) Kies uit het lijstje van standaard scripts: convertmts.scpt en klik Attach
    (8) Zet een vinkje bij Enable Folder Actions (als dat niet aan staat)
    (9) Sluit het Folder Actions Setup venster

    <br />
    on adding folder items to this_folder after receiving these_items<br />
      repeat with i from 1 to number of items in these_items<br />
        set this_item to item i of these_items<br />
        tell application "Finder"<br />
          set the videoFile to the POSIX path of this_item<br />
          set file_ext to the name extension of this_item<br />
        end tell<br />
        if the file_ext is "MTS" then<br />
          set ffmpegOptions to "-deinterlace -vcodec mpeg4 -b 16M -strict experimental -acodec aac -ac 2 -ab 128k"<br />
          set convertedVideoFile to videoFile & ".m4v"<br />
          set shellCmd to "/usr/local/bin/ffmpeg -i '" & videoFile & "' " & ffmpegOptions & "  '" & convertedVideoFile & "'"<br />
          do shell script shellCmd<br />
        end if<br />
      end repeat<br />
    end adding folder items to<br />
     

    Let op: (bug in forumsoftware) Vervang de “&amp ;” (7x) in het

     

    stuk hierboven door "&".

    De gebruikte conversie-parameters kunnen aangepast worden door "ffmpegOptions" te wijzigen.

    Bijdrager
    Wiki Post

    Bijdrager
    Pieterr
    Bijdrager
    r.heijma

    Prachtig Pieterrrrrrr,

    Ik heb nog een hoop m2ts HD vakantie files van mijn windhoos tijd. Kan ik ze nu lekker bewerken in iMovie.
    Heb ik wat te doen tijdens regenachtige dagen.

    Hartelijk bedankt.

    Grtz, René.

    Inactief
    Anoniem

    ik heb alle stappen doorlopen, maar er gebeurd niets als ik een MTS file in de map gooi.
    hoe kan ik controleren of alles naar behoren is geïnstalleerd ?

    Bijdrager
    Pieterr

    Misschien staat ffmpeg bij jou op een andere plek?

    Kun je eens in Terminal dit commando geven:

    which ffmpeg

    Bij mij komt er dan te staan:

    /usr/local/bin/ffmpeg
    Inactief
    Anoniem

    bij mij lijkt het dezelfde lokatie te zijn

    <br />
    Last login: Sun Oct 17 17:35:43 on ttys000<br />
    XenoiMac-5:~ Xeno$ which ffmpeg<br />
    /usr/local/bin/ffmpeg<br />
    XenoiMac-5:~ Xeno$ </p>
    <p>
    Bijdrager
    Pieterr

    Ik weet niet precies hoe het met de case-aware filenames wordt afgehandeld.
    Heeft jouw bestand de MTS extensie (in hoofdletters)?

    Inactief
    Anoniem

    de files komen van een Sony Hd cam en hebben inderdaad hoofdletters .MTS

    Bijdrager
    Pieterr

    Kun je achter de “end tell” de volgende regels zetten in het AppleScript:

    set shellCmd to "echo AAP > ~/Desktop/aap.txt"<br />
    do shell script shellCmd

    Als je nu een bestand in de map sleept, zou je een bestand “aap.txt” op de Desktop moeten krijgen. Als dit niet gebeurt, wordt de Folder Action niet getriggerd.

    Inactief
    Anoniem

    bij het toevoegen van een MTS file gebeurd niets:?

    Bijdrager
    Pieterr

    Zie boven

    Inactief
    Anoniem

    zou de install van xcode er mee te maken kunnen hebben ?, ik ben daar niet mee bekend en qua bestand ook een beetje groot 2.45 Gb

    Bijdrager
    Pieterr

    Kun je in stap (8) het vinkje nog een keer expliciet uit- en weer aanzetten.
    Ik herinner me dat ik hier ook ooit een probleem mee had.

    Bijdrager
    Pieterr

    Nee, ik denk niet dat het probleem in Xcode zit.
    Wat zie je als je in Terminal ingeeft:

    ffmpeg -version

    Als je dan ffmpeg versieinfo te zien krijgt is het hele Xcode deel goed gegaan.

    Inactief
    Anoniem

    Stap 8 herhaald, en gebeurt weer niets:)

    <br />
    Last login: Sun Oct 17 17:50:52 on ttys000<br />
    XenoiMac-5:~ Xeno$ ffmpeg -version<br />
    FFmpeg version 0.6, Copyright (c) 2000-2010 the FFmpeg developers<br />
      built on Oct 17 2010 17:26:24 with gcc 4.2.1 (Apple Inc. build 5664)<br />
      configuration:<br />
      libavutil     50.15. 1 / 50.15. 1<br />
      libavcodec    52.72. 2 / 52.72. 2<br />
      libavformat   52.64. 2 / 52.64. 2<br />
      libavdevice   52. 2. 0 / 52. 2. 0<br />
      libswscale     0.11. 0 /  0.11. 0<br />
    FFmpeg 0.6<br />
    libavutil     50.15. 1 / 50.15. 1<br />
    libavcodec    52.72. 2 / 52.72. 2<br />
    libavformat   52.64. 2 / 52.64. 2<br />
    libavdevice   52. 2. 0 / 52. 2. 0<br />
    libswscale     0.11. 0 /  0.11. 0<br />
    XenoiMac-5:~ Xeno$ </p>
    <p>
    Bijdrager
    Pieterr

    Geen aap.txt op je Desktop ?

    Bijdrager
    Pieterr

    Probeer eens je Mac een keer opnieuw op te starten. Ik zoek ff wat er nog meer met onwillige Folder Actions aan de hand kan zijn.

    Inactief
    Anoniem

    jammer genoeg niets, geen aap op de desktop,
    ik ga nu een herstart doen.

    Inactief
    Anoniem

    herstart uitgevoerd, MTS file in de map gesleept, en geen aap op de desktop :), en verder geen actie.
    ik heb een vermoeden dat de xcode niet geïnstalleerd is, mijn dvd werkt niet meer (zoals vele imacs) en heb de xcode.dmg van het net gepluk en die geïnstalleerd.

    Bijdrager
    Pieterr

    Die Xcode heb je helemaal niet meer nodig. Die was alleen nodig om ffmpeg te bouwen.

    Het probleem zit h’m in de trigger van de Folder Action.

    Bijdrager
    Pieterr

    Als de reboot ook niet geholpen heeft:
    Kun je eens dubbelklikken op het bestand
    ~/Library/LaunchAgents/com.apple.FolderActions.folders.plist
    en kijken wat daar in staat:

    Inactief
    Anoniem

    Bijdrager
    Pieterr

    Dat die WatchPaths leeg zijn, klopt niet!

    Je zou er eentje moeten hebben. (Ik heb er twee, want ik heb ook zo’n Folder Action voor ExifTool)

    Bijdrager
    Pieterr

    Gooi die twee .plists eens weg (in LaunchAgents) en start dan nog een keer opnieuw op.
    Daarna (eventueel) nog een keer de stappen herhalen om het AppleScript aan de “Videos” map te hangen.

    Inactief
    Anoniem

    hmm, “enable folder actions” was weer uitgevinkt, na aanvinken kwam er wel een aap file op de desktop en een m4v file in de folder, maar de m4v file was maar 5mb, tov 81 mb original file formaat, en de m4v is niet af te spelen.

    er is vordering:)

    EDIT: ik ben gewoon te ongeduldig, na een minuutje was de file groter en afspeelbaar.
    het blijkt nu te werken, dank:)

    Bijdrager
    Pieterr

    Aha! Goed nieuws!:lol:

    Bedenk dat de conversie enige tijd kost. Er komt dus direct een M4V bestand, maar dat is nog niet compleet. Kijk anders naar je “CPU” in Activiteitenweergave. Als die terugzakt, is de conversie klaar.

    Inactief
    Anoniem

    mijn dank is groot, nu kan ik 128GB om gaan zetten:)

    Bijdrager
    Pieterr

    Succes!:wink:

    Inactief
    Anoniem

    tijdens het converteren van een aantal MTS files zag ik dat er toch meer artifacts in de m4v bestanden zitten dan ik zou willen, is er een mogelijkheid om de kwaliteit op te krikken ?

    en kan ik tijdens het converteren de actie stop zetten ?, mijn iMac bleef maar doorgaan met het converteren, zelfs na het verwijderen van de MTS files uit de map :), pas na een herstart was de actie gestopt.

30 berichten aan het bekijken - 1 tot 30 (van in totaal 40)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.