26 berichten aan het bekijken - 1 tot 26 (van in totaal 26)
  • Q:
    Bijdrager
    J-R0eN

    Apache installeren

    hallo allemaal,

    ik heb sinds vandaag mn nieuwe mac binnen (met intel processor) en probeer apache 2 te installeren.
    Omdat ik het op mn andere mac al heb gedaan weet ik hoe het moet. Maar nu wil ik het op mn nieuwe mac installeren en lukt dit niet. Apache zelf installeren lukt wel, maar het onderdeeltje prefpane niet.
    Ik krijg steeds de foutmelding : u kunt het voorkeuren paneel op deze computer niet openen, en overnieuw installeren geeft dezelde foutmelding :|

    mijn vraag is:

    zijn er al meer mensen gestuit op dit probleem? en zijn der al oplossingen enz?

    alle info is welkom

    bedankt

    J-R0en :apple:

    Bijdrager
    HSL

    probeer je apache2 gewoon te downloaden van apache.net
    en dan te compilen of heb je een of andere gare package?

    Bijdrager
    J-R0eN

    neej, van de site die genoemt wordt in de tutorial van forumlid Larz :

    http://forum.macosx.nl/viewtopic.php?p=732104&highlight=how#732104

    Bijdrager
    HSL

    dat gaat niet werken op een intel mac.

    je moet xcode installeren en dan apache zelf downloaden en compilen,
    of gewoon genoegen nemen met apache 1.3
    :)

    voor de meeste doeleinden is 1.3 wel voldoende toch?

    Bijdrager
    J-R0eN

    jah denk het wel, heb der voorderest ook geen verstand van
    maar linkje misschien

    Inactief
    Anoniem

    Apache1.3 zit standaard al in Tiger. Er zijn diverse online tutorials te vinden, bijvoorbeeld bij macdevcenter.

    Bijdrager
    HSL
    ”J-R0eN”

    jah denk het wel, heb der voorderest ook geen verstand van
    maar linkje misschien

    systeem voorkeuren > delen > services > web

    en klaar.

    Bijdrager
    J-R0eN

    HUh? als ik dat aanzet kan ik dan PHP via localhost kijken?
    want dat is de bedoeling, en dat gaat via apache …

    Bijdrager
    computer space
    ”J-R0eN”

    HUh? als ik dat aanzet kan ik dan PHP via localhost kijken?
    want dat is de bedoeling, en dat gaat via apache …

    Ja, maar dan moet je PHP ook activeren.
    klik

    Bijdrager
    J-R0eN

    bedankt voor je link, maar ik snapp het echt niet, ben geen programmeur ofzow :mrgreen:

    ik moet zegge het ziet er niet moeilijk uit, het zijn maar 2 stappen, alleen weet ik niet waar ik die 2 stappen moet uitvoeren? zou iemand dat kunnen vertellen..

    srry voor mn dommigheid :|

    Bijdrager
    computer space

    Intypen die tekst in Terminal!

    Bijdrager
    J-R0eN

    durf niet zomaar wat in de terminal te doen dus eerst maar even hier om te testen:

    stap 1:
    $ sudo vi /etc/httpd/httpd.conf
    Password:

    stap 2:
    LoadModule php4_module libexec/httpd/libphp4.so

    AddModule mod_php4.c

    en dan? is het klaar?

    edit: ik werk op een mac met intelprocessor versie 10.4

    Bijdrager
    computer space

    Gewoon die stappen volgen. Wat je doet is een tekstbestand aanpassen dat alleen met root-rechten is te bewerken. Indien je het fijner vind kun je ook inloggen als root en de boel met teksteditor wijzigen.

    Bijdrager
    J-R0eN

    hmm ik snap er echtt helemaal nix van. Ik typ het nu dus in de terminal en het enige wat die steeds zegt is : -bash: $: command not found? :| :| :| :| :|

    Bijdrager
    J-R0eN

    Er moet tog wel iemand op dit forum zijn die in een paar duidelijke en begrijpbare stappen kan uitleggen hoe je het kan installeren….

    Inactief
    Anoniem

    Type eerst dit: [code:1:f8a47dcc1e]sudo vi /etc/httpd/httpd.conf[/code:1:f8a47dcc1e]
    gevolgd door een Enter. Dan vraagt de terminal om je paswoord wat je dan intyped, weer gevolgd door een Enter. Vervolgens pas je het geopende document aan volgens het artikel in de link. Wanneer je TextWrangler heb geinstalleerd, kun je ook [code:1:f8a47dcc1e]sudo edit /etc/httpd/httpd.conf[/code:1:f8a47dcc1e]
    typen. Dan kom je in een wat gebruikersvriendelijker teksteditor om het bestand aan te passen.

    Bijdrager
    HSL

    als je dit niet snapt kan je er beter niet aan beginnen, en gewoon lekker ergens webhosting afnemen, das veel makkelijker.

    :)

    Inactief
    Anoniem
    ”J-R0eN”

    Er moet tog wel iemand op dit forum zijn die in een paar duidelijke en begrijpbare stappen kan uitleggen hoe je het kan installeren….

    Geduld is een deugd – er zal heus wel iemand antwoorden, dit is geen servicedesk.:roll:

    Bijdrager
    J-R0eN

    @ koen : bedankt voor je hulp, ik ga der mee aan de slag, en i.d.d daar heb j helemaal gelijk in, kwerd het alleen een beetje spuugzat na dat ik al 2/3 uur aan het kloten ben..

    Bijdrager
    iPod Jimmy

    Kan ik dan als ik dit allemaal doen nu ook PHP kijken vanuit Dreamweaver in Safari?

    Inactief
    Anoniem
    ”J-R0eN”

    @ koen : bedankt voor je hulp, ik ga der mee aan de slag, en i.d.d daar heb j helemaal gelijk in, kwerd het alleen een beetje spuugzat na dat ik al 2/3 uur aan het kloten ben..

    Succes dan maar, want dit is nog maar het begin:P

    Bijdrager
    Deskman

    Ja, dat kan.

    PHP installeren is misschien makkelijker dan vanuit VI op PICO zelf aanzetten. Bovendien mist PHP (tot nu toe) wel war libs.

    kijk op entropy.ch voor een klik-klik-installer.

    Of op http://www.serverlogistics.com (en houd het nou lekker bij de ingebouwde apache als je niet zeker weet dat je Apache-2 functies nodig hebt)

    Bijdrager
    a la Mac
    ”J-R0eN”

    hmm ik snap er echtt helemaal nix van. Ik typ het nu dus in de terminal en het enige wat die steeds zegt is : -bash: $: command not found? :| :| :| :| :|

    Die dollar ervoor moet je niet intypen;)

    Bijdrager
    HSL
    ”Deskman”

    Ja, dat kan.

    PHP installeren is misschien makkelijker dan vanuit VI op PICO zelf aanzetten. Bovendien mist PHP (tot nu toe) wel war libs.

    kijk op entropy.ch voor een klik-klik-installer.

    Of op http://www.serverlogistics.com (en houd het nou lekker bij de ingebouwde apache als je niet zeker weet dat je Apache-2 functies nodig hebt)

    nou nee, dan ga je allemaal extra dingen installeren terwijl je maar 2x een “#” moet weghalen om php te activeren, en daar komt nog bij dat die installers niet werken op intel machines.:)

    Bijdrager
    Deskman

    Oeps… Dat zal inderdaad wel niet.

    Bijdrager
    wytschaaf

    Ik heb de handleiding ook gevolgd maar helaas zonder gunstig resultaat.
    Heb Apache 2 nog steeds niet werkend en als ik het prefpane wil installeren geeft hij een foutmelding nadat ik de keuze heb gemaakt voor wie hij beschikbaar moet zijn.
    PHP4 werkt overigens wel goed op de huidige apache (die comments weggehaald in httpd.conf)

    Vervolgens probeerde ik MySQL te installeren de installatie gaf geslaagd aan, maar vervolgens werkt hij niet. Ook dit prefpane werkt niet.

    Wanneer ik de functie mysql_connect aanroep via php krijg ik de volgende melding:
    Warning: mysql_connect(): Can’t connect to local MySQL server through socket ‘/var/mysql/mysql.sock’ (2) in /Users/gebruiker/Sites/test.php on line 2

    Ik werk op een intel mac mini solo.

26 berichten aan het bekijken - 1 tot 26 (van in totaal 26)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.