13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)
  • Q:
    Bijdrager
    ingrid

    Afbeeldingen in Internet Explorer schuiven door het menu

    De site http://www.dsasoftware.nl heb ik gemaakt met RapidWeaver met het Diamond Theme. Zoals op bijgaande screenshot te zien is, schuift de afbeelding van het software-pakketje door het menu heen in Internet Explorer op Windows. Terwijl de andere plaatjes wel op de goede plek staan. Alle andere browsers geven het wel goed weer. Is er iemand die enig idee heeft hoe ik dat moet oplossen in de CSS.

    Bijdrager
    iJoost

    Hij geeft een fout. Misschien is dat het:

    [code:1:5e1f865deb]Error: Expected ‘,’ or ‘{’ but found ‘html’. Ruleset ignored due to bad selector.
    Source File: http://www.dsasoftware.nl/
    Line: 87[/code:1:5e1f865deb]

    Bijdrager
    ingrid

    Zou die fout in de index.html moeten zitten of in de .css file?

    Bijdrager
    inflicted

    In de css denk ik:
    [code:1:09233dbba9].image-left {
    display: table;
    }

    .image-left img {
    display: inline;
    float: left;
    padding: 0px 10px 10px 0px;
    }[/code:1:09233dbba9]

    Bijdrager
    iJoost

    Volgens mij zegt ie in die foutmelding welk bestand het is.;-)

    Maar weet je wat? FireFox. JavaScript console open. Pagina opvragen. Klik op de foutmelding en… voila!

    Bijdrager
    ingrid
    ”iJoost”

    Volgens mij zegt ie in die foutmelding welk bestand het is.;-)

    Nou het lijkt me dan dat de index.html is, maar daar kan ik die fout niet terugvinden

    Maar weet je wat? FireFox. JavaScript console open. Pagina opvragen. Klik op de foutmelding en… voila!

    Dat heb ik ook gedaan, maar schiet mij maar naar Mars. Daar begrijp ik dus helemaal niks van. Waar zit ik dan naar te kijken???? Javascript?????

    Ik heb juist gekozen voor RapidWeaver omdat ik me over dit soort dingen allemaal niet druk wil maken. De vraag is nu dus: is het een fout van RapidWeaver of van de bouwer van het Diamond Theme?

    Of zal ik gewoon moeten accepteren dat IE nu eenmaal niet goed omgaat met CSS en hopen dat versie 7 dat beter gaat doen.

    Ik heb zowel de site als de CSS laten valideren en dat schijnt allemaal dik in orde te zijn.

    Bijdrager
    iJoost
    ”ingrid”

    Dat heb ik ook gedaan, maar schiet mij maar naar Mars. Daar begrijp ik dus helemaal niks van. Waar zit ik dan naar te kijken???? Javascript?????

    Nee, naar je eigen CSS.

    ”ingrid”

    Ik heb juist gekozen voor RapidWeaver omdat ik me over dit soort dingen allemaal niet druk wil maken.

    OK. Sorry, dat ik even dacht dat je gewoon met je CSS geholpen wilde worden.;-)

    Wat je zoekt is dan denk ik iemand die verstand heeft van RapidWeaver. Die “lopen” hier vast ook wel rond…

    (Zet anders even RapidWeaver in de titel van het draadje. Misschien trekt dat de juiste aandacht.)

    Bijdrager
    ingrid

    Precies, dat wilde ik ook maar ik krijg iets heel anders te zien. Heeft niks met mijn site te maken. Heb het nog eens geprobeerd. Ik type de URL in, open JavaScript Console en krijg de foutmeldingen van barfplaats.nl te zien. De site die ik daarvoor in Firefox open had. Vandaar dat ik waarschijnlijk even het spoor bijster was. :)

    Bijdrager
    inflicted

    Je hoeft je plaatje niet in een aparte div te zetten.
    Heb je het al geprobeerd met die css die ik hierboven geschreven heb?

    Check hier. Werkt ook in IE6!
    Het is gewoon een float probleem.

    Of is het iets anders?

    IE 6 geeft nogal wat problemen met css, maar daar
    kun je ook weer heel veel hacks voor vinden.

    Bijdrager
    ingrid
    ”inflicted”

    Je hoeft je plaatje niet in een aparte div te zetten.
    Heb je het al geprobeerd met die css die ik hierboven geschreven heb?

    Check hier. Werkt ook in IE6!
    Het is gewoon een float probleem.

    Of is het iets anders?

    IE 6 geeft nogal wat problemen met css, maar daar
    kun je ook weer heel veel hacks voor vinden.

    Ik heb dat plaatje niet in een aparte Div gezet, dat doet RapidWeaver voor me. Maar ik heb het opgelost door de pagina handmatig met Dreamweaver aan te passen en de plaatjes uit de aparte divs gehaald. En nu ziet het er wel netjes uit.

    Hopelijk lost IE 7 veel van dit soort problemen op en kan ik dit soort pagina’s weer gewoon helemaal met RapidWeaver maken.

    Bijdrager
    inflicted

    Het is natuurlijk beter als je gewoon weet wat je aan het doen bent.
    Een heel goed boek is bv. CSS Mastery van Andy Budd.

    Of gewoon alle tutorials op het net volgen, zo heb ik ook bijna alles geleerd.

    succes

    Bijdrager
    sidartha
    ”ingrid”

    Hopelijk lost IE 7 veel van dit soort problemen op en kan ik dit soort pagina’s weer gewoon helemaal met RapidWeaver maken.

    Het feit dat IE 7 die problemen dan oplost wil nog niet zeggen dat iedereen ook IE 7 meteen gaat gebruiken, we hebben nog jaren te maken met IE 6. Dus dat kan je helaas wel vergeten.

    Bijdrager
    vriesela

    Je kunt deze vragen over RW beter op de forum-website van RapidWeaver stellen. Binnen de kortste keren heb je antwoord.
    Met het genoemde theme en RW zou je geen problemen moeten hebben in IE.
    Zelf heb ik iets dergelijks ook met mijn RW-websites gehad, en de reden was dat de afbeelding te groot was. In Safari was alles OK, maar in IE verschoof er het een en ander.

13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.