7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)
  • Q:
    Bijdrager
    mac-addict

    actionscript 2 errors wie helpt mij ?

    Ik ben eigenlijk geen scripter maar ik wil toch proberen dit probleem op te lossen kan iemand mij vertellen hoe ik dit het beste kan aanpakken?

    <br />
    **Error** Scene=Scene 1, layer=lader, frame=1, Line 1: Clip events are permitted only for movie clip instances<br />
         onClipEvent(load) </p>
    <p>**Error** Scene=Scene 1, layer=lader, frame=1, Line 2: '{' expected</p>
    <p>**Error** Scene=Scene 1, layer=Layer 104 copy, frame=1, Line 1: Mouse events are permitted only for button instances<br />
         on(release) 

    **Error** Scene=Scene 1, layer=Layer 103 copy, frame=1, Line 1: Mouse events are permitted only for button instances
    on(release)

    **Error** Scene=Scene 1, layer=Layer 102 copy, frame=1, Line 1: Mouse events are permitted only for button instances
    on(release)

    **Error** Scene=Scene 1, layer=Rode tegel, frame=1, Line 1: Mouse events are permitted only for button instances
    on(release)

    **Error** Scene=Scene 1, layer=Blauwe tegel, frame=1, Line 1: Mouse events are permitted only for button instances
    on(release)

    **Error** Scene=Scene 1, layer=Layer 99 copy, frame=1, Line 1: Mouse events are permitted only for button instances
    on(release)

    **Error** Scene=Scene 1, layer=lader, frame=1, Line 2: ‘{‘ expected

    **Error** Scene=Scene 1, layer=Lader 2, frame=1, Line 2: ‘{‘ expected

    Total ActionScript Errors: 10, Reported Errors: 10

    Bijdrager
    dj bazzie wazzie

    Het ziet er naar uit dat je een muis event op een object hebt staan dat niet een button object is. Meest voorkomende fout is namelijk dat je je event koppelt aan het frame in de main timeline en niet aan de button instance zelf.

    Bijdrager
    mac-addict

    okay thnx ! hele duidelijke uitleg ik begrijp gelijk wat je bedoelt!

    Bijdrager
    mac-addict

    Okay… ik begrijp het blijkbaar nog niet, ik dacht dat u bedoelde dat ik een keyframe moest aanmaken en daar dan de actie toewijzen aan de button. Maar op deze manier werkt de button dus niet !

    Kunt u mij misschien vertellen hoe ik het foutloos script ?

    Bij voorbaat dank

    Bijdrager
    dj bazzie wazzie

    Ik blijf erbij dat ik denk dat je button geen instance van een button is. Ik ga ervan uit dat je een movie clip gebruikt hebt om een button te maken. Wanneer je dit doet moet je wel zorgen dat je movie clip een instance wordt van een button. In dit geval moet je de movieclip selecteren bij een on (release) in plaats van een keyframe van deze button.

    Hier een duidelijke uitleg met screenshots over buttons.

    Bijdrager
    mac-addict
    dj op 28 juni 2010

    Ik blijf erbij dat ik denk dat je button geen instance van een button is. Ik ga ervan uit dat je een movie clip gebruikt hebt om een button te maken. Wanneer je dit doet moet je wel zorgen dat je movie clip een instance wordt van een button. In dit geval moet je de movieclip selecteren bij een on (release) in plaats van een keyframe van deze button.
    Hier een duidelijke uitleg met screenshots over buttons.

    Screenshots zijn niet zichtbaar?

    Ik heb het probleem bijna opgelost simpel weg door bijna alle symbols in 1 layer te plaatsen, voor heens was elk object een aparte layer net als hoe je bijv. in photoshop zou werken.

    Alleen blijven er nog 2 errors over namelijk:

    <br />
    **Error** Scene=Scene 1, layer=Layer 67, frame=1, Line 1: '{' expected<br />
         onClipEvent(load)</p>
    <p>**Error** Scene=Scene 1, layer=Layer 67, frame=1, Line 1: '{' expected<br />
         onClipEvent(load)</p>
    <p>Total ActionScript Errors: 2,  Reported Errors: 2<br />
     
    Bijdrager
    mac-addict
    dj op 28 juni 2010

    Ik blijf erbij dat ik denk dat je button geen instance van een button is. Ik ga ervan uit dat je een movie clip gebruikt hebt om een button te maken. Wanneer je dit doet moet je wel zorgen dat je movie clip een instance wordt van een button. In dit geval moet je de movieclip selecteren bij een on (release) in plaats van een keyframe van deze button.
    Hier een duidelijke uitleg met screenshots over buttons.

    Screenshots zijn niet zichtbaar?

    Ik heb het probleem bijna opgelost simpel weg door bijna alle symbols in 1 layer te plaatsen, voor heens was elk object een aparte layer net als hoe je bijv. in photoshop zou werken.

    Alleen blijven er nog 2 errors over namelijk:

    <br />
    **Error** Scene=Scene 1, layer=Layer 67, frame=1, Line 1: '{' expected<br />
         onClipEvent(load)</p>
    <p>**Error** Scene=Scene 1, layer=Layer 67, frame=1, Line 1: '{' expected<br />
         onClipEvent(load)</p>
    <p>Total ActionScript Errors: 2,  Reported Errors: 2</p>
    <p>

    ( waarom komt trouwens niet al mijn code in een apart vlak)

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.