Firefox ondersteunt oude OS X-versies niet langer

Door: Raymon Mens - 10 reacties

Na Chrome stopt ook Firefox met onder­steuning voor OS X 10.6, 10.7 en 10.8. De browser van Mozilla vereist vanaf augustus minimaal OS X 10.9 Mavericks. Oude versies blijven op oude systemen werken, maar krijgen geen nieuwe functies of security updates.

Toch laat Mozilla gebruikers van oude OS X-versies niet helemaal in de steek. De “Firefox Extended Support Release” krijgt nog tot medio 2017 beveiligingsupdates en ondersteunt OS X vanaf 10.6 Snow Leopard.

Hoewel de Extended Support Release eigenlijk is gemaakt voor organisaties zoals scholen en bedrijven, kunnen eindgebruikers deze ook gewoon downloaden. Als je vast wil houden aan Snow Leopard, Lion of Mountain Lion, raden we je aan naar deze release te switchen.
Schermafbeelding 2016-05-02 om 12.47.13
Mozilla zoekt ook naar een manier de ondersteuning voor Windows XP te stoppen, zonder de miljoenen mensen die nog steeds gebruik maken van XP bloot te stellen aan veiligheidsrisico’s. De meest voor de hand liggende oplossing zou zijn om gebruikers aan te moedigen om te upgraden naar Windows 7. Probleem: 40-53% van de Firefox-gebruikers met XP kunnen niet upgraden omdat hun PC niet krachtig genoeg is.

Reacties

10 reacties
  • Profielfoto
    MEEUW

    Het word een beetje vervelend.
    OSX dwingt je te update. Of je krijg elke dag een herinnering met restart now of remind me …
    Geen keus dan morgen weer te herinneren. Terwijl ik niet wil updaten.

    Iphone idem, geen app start op geven moment meer op omdat er eerst ios geupdate moet worden. Elke dag herinnering om te update met ipad, iphone en alle andere apparaten.

    Prima allemaal, als de updates bug vrij zijn. Maar zolang allemaal niet bug vrij is……

  • Profielfoto
    Robin Verbeek

    Als je pc niet krachtig genoeg is om Windows 7 te draaien, dat ze dan een nieuwe kopen hè.

  • Profielfoto
    Shmoo
  • Profielfoto
    matsoftmac

    Het ‘dwingen’ van updaten doordat apps niet meer starten is al jaren. Kan me in de Mac Os 8.5 tijd nog herinneren dat apps niet meer opstarten omdat er een verouderde extentie op de Mac was geïnstalleerd.

  • Profielfoto
    Jasperr

    Jammer, Safari werkt al niet meer op 10.6.8 en nu gaat Firefox ook stoppen… Zonde dat Apple niet inziet dat 10.6.8 het beste os is!

  • Profielfoto
    Soulshaker

    En de browser opera ?

  • Profielfoto
    steveb

    Jammer, Safari werkt al niet meer op 10.6.8 en nu gaat Firefox ook stoppen… Zonde dat Apple niet inziet dat 10.6.8 het beste os is!

    hoe zo?
    ik heb ook een mak met osx 10.6.8 en safari werkt nog steeds.
    wat ik wel eigendaardig vind is dat de mac appstore voor deze snowleopard machine vorige maand wel nog een update kreeg.

  • Profielfoto
    Zakske

    En de browser opera ?

    Daar heb je minimaal 10.7 voor nodig, maar eigenlijk 10.9.

  • Profielfoto
    Zakske

    ik heb ook een mak met osx 10.6.8 en safari werkt nog steeds.

    De laatste versie van Safari die nog op 10.6 draait is zo lek als een vergiet.

  • Profielfoto
    computer space

    Tip: als je veiligheid wilt verbeteren en je browser weer omhoog wilt stoten in de statistieken:
    KOM MET JAVASCRIPT PERMISSIES!
    Gewoon per site per functie Javascript enablen/disablen.
    Volgens mij het gouden ei.
    Kun je bovendien in die oude OS-en standaard de onveilige Javascriptfuncties uitschakelen.
    Net als iOS en Windows Phone om zijn met app-permissies, wordt het tijd dat dit ook in de webbrowser gebeurt.

    Ik zou bijvoorbeeld standaard willen blokkeren:
    – Aanpassen shortcuts
    – Uitlezen muispositie
    – Uitlezen browser/OS/venstergrootte
    – Aanpassen copy-paste gedrag.