Boot Camp heeft in OS X El Capitan geen USB-stick meer nodig

14 reacties

Het installeren van Windows op een Mac is met OS X 10.11 El Capitan weer een stukje eenvoudiger geworden. Voor het gebruik van Boot Camp blijkt niet langer een USB-stick nodig. De tijdelijke installatiebestanden worden op een aparte partitie geplaatst.

Softwarebedrijf Two Canoes ontdekte de functie en wijdde er een blogpost aan. Het blijkt alleen te werken met de meest recente MacBook Air, MacBook Pro en Mac Pro. Andere Macs hebben nog een USB-stick nodig.

In OS X Yosemite en eerder is een USB-stick vereist om de installatie­bestanden van Windows op te zetten. In El Capitan wordt voor deze files een partitie genaamd ‘OS X Reserved’ aangemaakt en na de installatie van Windows weer verwijderd. Apple rept in de officiële Boot Camp-documentatie overigens nog niet over deze nieuwe functie.

Naast Boot Camp is het ook mogelijk om Windows in een virtuele machine op OS X te draaien. Zowel VMWare Fusion als Parallels zijn klaar voor Windows 10 en OS X El Capitan.

Reacties

14 reacties
  • Profielfoto
    Floris

    Dus de Macbook Air uit 2013 is niet ondersteund?

  • Profielfoto
    sciletto

    Ik heb een macpro uit 2009 waar aardig veel geld voor neer is gelegd maar er vallen steeds meer functies weg:( Bluetooth 4 moet er eigenlijk in en heel thunderbolt is gewoon niet ondersteund

  • Profielfoto
    Soulshaker

    de meest recente MacBook Air

  • Profielfoto
    Humain

    er vallen steeds meer functies weg:( Bluetooth 4 moet er eigenlijk in en heel thunderbolt is gewoon niet ondersteund

    het was wel een dure machine, maar wel een machine van dik 6 jaar oud natuurlijk. In computertermen is dat toch een benzinewagen met 3 ton op de teller.

  • Profielfoto
    polansky

    @Sciletto

    2009 – dat is op 2 maanden na dus een computer die 7 jaar oud is…
    En voor wat betreft bleutooth, je zou er gewoon zelf een USB stick in kunnen stoppen. Je kunt toch niet verwachten dat Apple na 7 jaar ineens ondersteuning gaat bieden voor een product dat al lang End Of Life is.

    Prijs je gelukkig dat je met die Mac al 7 jaar kunt werken.
    Iets wat je met een Windows systeem eigenlijk nooit voor elkaar had gekregen.

  • Profielfoto
    kees32

    Komop ik heb net nog een Early 2014 MacBook Air waarom zou de 2015 het wel kunnen en de mijne niet?

  • Profielfoto
    wensink

    2009 – dat is op 2 maanden na dus een computer die 7 jaar oud is…
    En voor wat betreft bleutooth, je zou er gewoon zelf een USB stick in kunnen stoppen. Je kunt toch niet verwachten dat Apple na 7 jaar ineens ondersteuning gaat bieden voor een product dat al lang End Of Life is.

    3 maanden*

    Maar ik heb er ook een en ik weet niet hoe je dit als ‘end of life’ kan beschouwen.. Deze machine doet het nog prima en ik kan er grotere logic projecten op draaien dan op de nieuwste MacBook Pro.

    Is er ook een echte reden dat dit niet op de oudere Macs kan?

  • Profielfoto
    IsSidha

    @wensink .. een Macbook Pro is wel even heel iets anders dan een Mac Pro.. dat is een Mercedes vergelijken met een roeiboot

    waarom lopen mensen altijd zo te zaniken over hun oude computers en wegvallende ondersteuning.. mijn 6 jaar oude auto wordt ook niet ondersteund met een gratis software update, ben je mal zeg, want dan moet het hele inspuit-mechanisme aangepast worden.

    bovendien valt het niet weg.. de hardware zit er simpelweg niet in omdat het toen nog niet eens bestond.. tjeeeeeee.. educate yourself please

  • Profielfoto
    wensink

    @IsSidha, dat snap ik ook wel, maar als de Mac Pro nu nog sneller is dan die nieuwe MacBook, hoe kun je hem dan achterhaald noemen?

    Daarbij wil ik jou dan vragen welke hardware er niet in deze Mac Pro kan die wel in die nieuwe zit waardoor het onmogelijk wordt om dit te kunnen? Want jij hebt jezelf zo goed onderwezen dat je dat ook wel weet lijkt me dan.

  • Profielfoto
    Milan_Dolk

    Zou je daar nog mee kunnen spelen in de info.plist?
    Ik heb een macbook uit 2010 en die is officieel niet supported voor windows 7 and up.
    Ik heb dat kunnen veranderen door in de info.plist een string te verwijderen.

    Misschien geldt dit ook wel voor dit.

    Als ik el capitan heb test ik het direct uit.

  • Profielfoto
    IsSidha

    @wensink .. een Ferrari uit 1950 is ook nog steeds sneller dan de gemiddelde Nissan Leaf.. maar je kunt geen stekker gebruiken om de tank vol te gooien.. tijden veranderen en ontwikkelingen gaan door.. de cpu die in jouw MacPro zit is bijvoorbeeld veel en veel groter dan de cpu’s die er nu in gaan

    en welke hardware.. begin maar met bluetooth.. de nieuwe 4.0 is gebaseerd op andere chips die zuiniger zijn en andere antennes die een breder bereik hebben.. ergo.. alles wat voor die aanpassingen uit is gekomen kan simpelweg geen 4.0 krijgen omdat de hardware dus verouderd is..

    en thunderbolt is natuurlijk niet ondersteund omdat er in die oude MacPro’s niet eens een aansluiting voor is omdat het nog niet eens bestond, dat bestaat pas sinds 2011

  • Profielfoto
    IsSidha

    ps.. is het daarom een slechte computer? zeker niet.. maar gaandeweg loop je gewoon tegen dit soort beperkingen op en moet je keuzes maken..

  • Profielfoto
    wensink

    @de 2 boven mij.. Dat geeft nog geen antwoord op mijn vraag.

  • Profielfoto
    IsSidha

    oh.. je kunt er genoeg inproppen maar dat is niet standaard geleverd en dus niet ondersteund.. en dan ben je ook helemaal op jezelf aangewezen.

    elke helpdesk, voor wat voor soort computer ook, zal eerst zeggen dat je al je meuk eraf moet halen.. scanners, printers etc.. om je daarna een complete clean install te laten doen.. werkt alles? prima, fijne dag weer.

    dat is niet alleen Apple, het is iedereen.. bel Dell maar eens

    dus mijn eerdere comment geeft antwoord op je vraag, nee, je hardware is dermate verouderd dat de nieuwe mogelijkheden er niet in zitten. einde verhaal

    wil je het perse toch hebben moet je gaan knutselen, dan verbreek je daarmee de overeenkomst met Apple die je bij aanschaf bent aangegaan en ben je op jezelf aangewezen om het maar werkend te krijgen.

    dat je niet naar de Apple store kunt gaan voor een upgrade is ook logisch.. juist daarmee creëer je een oerwoud aan configuraties die niet meer te overzien zijn en slaat de kreet “it simply works” nergens meer op en wordt het meer de windows versie “plug and pray”