One More Thing » Community » Forum » Mac Software » macOS » [opgelost] PHP versie upgraden lukt niet

[opgelost] PHP versie upgraden lukt niet

Profielfoto van BeMacUser

BeMacUser op 16 februari 2017 #

Hallo,

Ik draai Mac OS X El Capitan. Hierop draait standaard PHP 5.5.38 Nu heb ik ondertussen MAMP PRO geïnstalleerd omdat hiermee heel eenvoudig hosts te maken zijn (Ik bouw websites met het Laravel Framework).
Als je MAMP PRO opstart, kan je kiezen welke PHP versie moet draaien. Ik heb daar PHP 7.1 ingesteld. (als ik dan phpinfo(); run, zie ik inderdaad PHP 7.1 staan. maar het probleem is dat, wanneer ik in mijn terminal ‘php -v’ run, er nog steeds PHP 5.5.38 wordt getoond.
Zo kan ik onmogelijk mijn Laravel websites draaien (omdat die minimaal versie 5.6 vereisen).
Ook composer update geeft foutmeldingen omdat de php versie te laag is.
Hoe upgrade ik de standaard PHP versie van mac naar de 7.1?
Ik heb reeds geprobeerd om “curl -s http://php-osx.liip.ch/install.sh | bash -s 7.1″ te runnen vanuit terminal, dit geeft geen foutmelding, maar daarna is mijn php -v nog steeds de 5.5.38
Kan iemand mij helpen aub?
Alvast bedankt!

  • Dit onderwerp is gewijzigd 1 week, 1 dag geleden door Profielfoto van Night Night. Reden: Titel aangepast
Profielfoto van veenbeest

veenbeest op 16 februari 2017 #

http://stackoverflow.com/questions/4262006/how-to-use-mamps-version-of-php-instead-of-the-default-on-osx

Succes

Profielfoto van EagerB0bNerd

EagerB0bNerd op 16 februari 2017 #

Of kijk eens naar AMMPS in plaats van MAMP PRO, zoveel makkelijker( naar mijn mening)
http://www.ampps.com

AMMPS heeft een installer waarmee je heel makkelijk applicaties kan installeren, ook laravel
http://www.ampps.com/apps/frameworks/Laravel

Tenslotte wil je nog je nog je os x configureren:
https://www.dvdheiden.nl/2015/11/07/os-x-configuring-webserver-for-laravel/

Profielfoto van computer space

computer space op 16 februari 2017 #

Of draai een Raspberry Pi als server. Kun je ook veel beter live laten draaien dan je mac.

Profielfoto van BeMacUser

BeMacUser op 16 februari 2017 #

Het artikel van veenbeest heeft me geholpen!

Ik moest mijn bash_profile aanpassen. (de PATH aanpassen naar mijn PHP 7.1.1 locatie.)

Nu werkt alles zoals het moet! Bedankt!

Ik ga zeker die ampps een keer bekijken! interessant!

Bedankt allemaal voor jullie reactie!

Groetjes,

Over dit topic

Gestart op 16 februari 2017 door BeMacUser

Laatste reactie door BeMacUser

Je kunt alleen reageren met een gratis OMT account.
Heb je geen OMT account? Registreer je dan nu gratis!

Inloggen

 

of Wachtwoord resetten?