One More Thing » Community » Forum » Pro » Audio & Video » mp4 speelt niet af op ipad

mp4 speelt niet af op ipad

The Gimp

The Gimp op 08 juni 2010 #

hey iedereen,

ik heb net een iPad en heb me enkele weken bezig gehouden met mijn films en series om te zetten naar mp4 voor op de iPad af te spelen.

nu blijkbaar wilt de iPad mijn HD films niet afspelen. mijn werkwijze om ze om te zetten is als volgt:

1) ik heb een elgato turbo 264 HD, met het bijhorende programma zet ik MKV’s om naar .mp4
2) ik heb ook roadmovie gekocht, met dit programma brand ik de ondertitels in het mp4 bestand.
3) ik sync ze met mijn ipad, maar blijkbaar wilt dit niet lukken…

edit: de codecs in het bestand zitten zijn: H.264, AAC, AC3 (via info van het videobestand)

iemand een idee hoe dit komt ?

thanx !

Qmagic

Qmagic op 08 juni 2010 #

Waarschijnlijk zal het audio AC3 het probleem zijn.
ElgatoTurboHD heeft een Beta versie met iPad instellingen, zover ik heb kunnen ontdekken deze komen overeen met de AppleTv instellingen alleen geen AC3 (alleen AAC Stereo).
Dus probeer het met de instelling “AppleTv met Dolby uitzetten”. Hoogstwaarschijnlijk lukt het dan wel.

The Gimp

The Gimp op 08 juni 2010 #

kan ik dit dan doen vanuit de mp4 die ik uiteindelijk kreeg.. ?

en moet ik dan die beta versie downloaden of niet ?

bedankt alvast !

The Gimp

The Gimp op 08 juni 2010 #

ok, ik heb het gevonden,

hij is nu de mp4 met subs en al aan het omzetten, ik hoop dat het werkt… anders voor niets al mijn films omgezet…

Qmagic

Qmagic op 08 juni 2010 #

Als je “Quicktime 7 Pro” hebt kan je vrij eenvoudig je AC3 kanaal verwijderen zonder opnieuw te renderen. Anders wordt het opnieuw renderen.

The Gimp

The Gimp op 08 juni 2010 #

ik vrees ervoor.. ik heb het net geprobeerd en het is niet gelukt…

nu ik had wel een licentie voor Quicktime 7 pro, nu “Gebruik” ik Quicktime X. kan je me ook nog zeggen hoe ik dat kanaal kan verwijderen… het deinstalleren van Quicktime X enzo kan ik zelf wel aan uit normaal…

thx!

Qmagic

Qmagic op 08 juni 2010 #

Quicktime 7 staat binnen OSX 10.6 in hulpprogramma’s, staat deze er niet tussen kan deze mbv je installatie cd opnieuw installeren en dan je licentie invoeren.
Met Quicktime X kan je dit niet aanpassen/verwijderen.
Als je deze file opent in quicktime 7 ga dan naar “venster” en dan “Toon filmkenmerken” (command+J / appeltje+J). Dan zie je je audiosporen en een button “verwijderen”, dan alleen nog opnieuw opslaan als zelfstandig film.

The Gimp

The Gimp op 08 juni 2010 #

maar is dat dan geen .mov die zelfstandige film ? dan moet ik die toch terug converteren of ben ik daar verkeerd in ?

sebiet eens proberen !

The Gimp

The Gimp op 08 juni 2010 #

ik denk dat die AC3 codec er ondertussen reeds uit is..
hetgeen ik in QT7 te zien krijg is dit scherm..
[URL=http://img248.imageshack.us/i/spart.png/ ][IMG]http://img248.imageshack.us/img248/2230/spart.png[/IMG][/URL]
Uploaded with [URL=http://imageshack.us]ImageShack.us[/URL]
het zou dan toch in orde moeten zijn, niet? het lukt alvast nog steeds niet om hem op men iPad te krijgen..
kan het iets te maken met filesize enzo ?

Qmagic

Qmagic op 08 juni 2010 #

Bij opslaan als zelfstandig film in quicktime wordt de extentie inderdaad .mov
Maar .mov .mp4 en .m4v kunnen allemaal dezelfde inhoud hebben. Als .mov niet werkt (waar ik niet vanuit ga) kan je het ook terug hernoemen (in finder) naar .mp4 of .m4v , dus converteren is hierbij niet nodig.
.m4v wordt meer bij appletv gebruikt (met name als er AC3 bij is) en .mp4 wordt meer bij iPod gebruikt (als er 1 audio track is).

The Gimp

The Gimp op 08 juni 2010 #

ok, op hoop van zegen. nu even studeren en dit ga ik straks eens even testen, heb hem nu wijselijk even weggelegd zodat ik me kan concentreren op het studeren :o)

in ieder geval al heel hard bedankt voor de hulp. ik hoop echt dat het werkt.

nu nog een ander vraagje.

wat kan ik best instellen bij de Elgato in het vervolg ? die apple tv preset met AC3 niet, of kan ik de gewone 720p preset nemen en daar eveneens AC3 laten uitschakelen?

thx !

Qmagic

Qmagic op 08 juni 2010 #

The op 08 juni 2010

ik denk dat die AC3 codec er ondertussen reeds uit is..
hetgeen ik in QT7 te zien krijg is dit scherm..
[URL=http://img248.imageshack.us/i/spart.png/ ][IMG]http://img248.imageshack.us/img248/2230/spart.png[/IMG][/URL]

Wat je hier ziet is dat soundtrack 2 je AC3 (dolby) nog steeds aanwezig is! deze moet je selecteren en op Delete drukken. De vinkjes die je bij enabled ziet staat betekend in deze situatie dat soundtrack 1 de hoofdspoor is en dat quicktime player hiervoor zal kiezen. Maar vinkje uit betekend dat deze er niet is aanwezig is. Een AppleTv maakt hiervan weer gebruikt bij zijn digitale uitvoer.
Dus ik denk voor je iPad dat deze AC3 niet mag voorkomen in de container.
Dus selecteer soundtrack 2 en deleten, dan opslaan.

Qmagic

Qmagic op 08 juni 2010 #

bij settings ipad kan ik geen dolby selecteren :

dus bij preset appletv uitzetten:

Preset 720p is hetzelfde als appletv alleen kan een hogere bitrate krijgen. Ik weet niet of de iPad dat aankan. kan ik ook niet terug vinden:

Settings voor iPad zijn:
H.264 video tot 720p, 30 beelden per seconde, Main Profile level 3.1 met AAC-LC audio tot 160 Kbps, 48 kHz, stereogeluid in .m4v-, .mp4- en .mov-bestandsstructuren;
MPEG-4-video tot 2,5 Mbps, 640 x 480 pixels, 30 beelden per seconde, Simple Profile met AAC-LC audio tot 160 Kbps, 48 kHz, stereogeluid in .m4v-, .mp4- en .mov-bestandsstructuren

The Gimp

The Gimp op 08 juni 2010 #

Waar vind ik die beta-versie ergens?! :)

The Gimp

The Gimp op 08 juni 2010 #

Kan het zijn dat mijn files te groot zijn?! Het zijn nl 1280x720p bestanden, dir nr aanleiding vd 2de paragraaf, want hij moet nrml toch hd aankunnen?!

Qmagic

Qmagic op 08 juni 2010 #

http://forums.elgato.com/viewtopic.php?f=128&t=7968
moet je even op de site naar de link van build 1.0.4b25 zoeken (ergens halverwege). Let op dit is een beta! (deze versie heeft wel problemen met mkv, de rest werkt wel goed). Maar heeft wel de iPad preset.

The Gimp

The Gimp op 08 juni 2010 #

owkej,

ik zal het eens proberen. ik heb net de werkwijze gevolgd die jij dacht dat moest werken, maar blijkbaar nog steeds niet… :(

nu ga ik de beta versie eens downloaden, om vervolgens mijn mp4(incl. subs, zonder AC3, dus de omzetting van MOV naar mp4 door extensie te veranderen) en dan dus om te zetten naar mp4..

nu, even mijn laatste vraag herhalen, zou het niet kunnen doordat mijn resolutie 1280×720 is dat hij em niet aanvaard.. ?

The Gimp

The Gimp op 08 juni 2010 #

tevens heb ik gemerkt in Turbo HD dat ik bij de other setting (van 720p preset) de dolby digital op automatisch staat, dus waarschijnlijk is die daar ingebakken ? jammer genoeg…

Qmagic

Qmagic op 08 juni 2010 #

The op 08 juni 2010

nu, even mijn laatste vraag herhalen, zou het niet kunnen doordat mijn resolutie 1280×720 is dat hij em niet aanvaard.. ?

Volgens de gegevens die ik bij apple.com vind  (H.264 video tot 720p) zo dit goed moeten zijn, tenzij er bij de codec instellingen iets anders fout gaat bij het converten: maximaal “Main Profile level 3.1″ (dit kan je checken met het gratis programma “MediaInfo Mac”).
Anders zou je het 720p (mp4 bestandje eens door iTunes moeten laten “converteren naar iPad” (zal wel langer duren). Maar dan moet je eens kijken wat iTunes er van maakt (resolutie, bitrate, etc).

The Gimp

The Gimp op 08 juni 2010 #

en daar hebben we de fout gevonden.

zoals je kan zien bij main profile staat er 3.2 , en dat zal dus 3.1 moeten zijn..
[URL=http://img534.imageshack.us/i/mainxkx.png/ ][IMG]http://img534.imageshack.us/img534/8158/mainxkx.png[/IMG][/URL]

Uploaded with [URL=http://imageshack.us]ImageShack.us[/URL]
en dan nu de volgende vraag.. who the hell kan ik dit veranderen ? :o)

The Gimp

The Gimp op 08 juni 2010 #

Ok, ik heb gevonden dat je bij turboHD de main profile kunt instellen, ik heb nu even de upad-preset gepakt en bij profile stond automatisch, maar ik heb toch mazr voor zekerheid 3.1 geselecteerd.

Nu zou het in theorie moeten lukken.. :)

Qmagic

Qmagic op 08 juni 2010 #

Precies, maar dat houd dus in dat alles opnieuw omgezet moet worden. Succes.

The Gimp

The Gimp op 08 juni 2010 #

Inderdaad…. Nuja, snachts kan dit zo geen kwaad… En ik denk dat het enkel de hd-series zijn en dat zijn er 3of4 ofzo!.

In ieder geval enorm bedankt voor de hulp, ik zal je strax nog laten weten of hrt gewerkt heeft…

The Gimp

The Gimp op 08 juni 2010 #

Het werkt dus! Een nadeel is dat ik de oorspronkelijke bestanden trug ga moeten downloaden omdat ik toch wel wat kwaliteitsverlies heb met momenten.. ( veel blokjes) en dat is met al dat omzetten e.d.  Narmtuurlijk vrij logisch…

Over dit topic

Gestart op 08 juni 2010 door The Gimp

Laatste reactie door The Gimp

Je kunt alleen reageren met een gratis OMT account.
Log in.

Inloggen